한국어 Translate to English (by Google) 日本語に??します (by excite.co.jp)

totem Quicktime demuxer 플러그인이 없다고 할 때

2011. 6. 23. 19:14

 

 $ totem test.avi

(totem:9290): WARNING : Could not create element 'gconfaudiosink'

(totem:9290): WARNING : Could not create element 'gconfvideosink'
Cannot connect to server socket err = 그런 파일이나 디렉터리가 없습니다
Cannot connect to server socket
jack server is not running or cannot be started
Cannot connect to server socket err = 그런 파일이나 디렉터리가 없습니다
Cannot connect to server socket
jack server is not running or cannot be started
** Message: Error: Your GStreamer installation is missing a plug-in.
gstdecodebin2.c(3233): gst_decode_bin_expose (): /GstPlayBin2:play/GstURIDecodeBin:uridecodebin0/GstDecodeBin2:decodebin20:
no suitable plugins found

** Message: Missing plugin: gstreamer|0.10|totem|Quicktime demuxer|decoder-video/quicktime, variant=(string)iso (Quicktime demuxer)
** Message: Automatic missing codec installation not supported (helper script missing)

 

해결 : sudo ln -s /usr/lib/gstreamer-0.10/libgstisomp4.so /usr/lib/gstreamer-0.10/libgstqtdemux.so
이유 : The qtdemux plugin has been renamed to isomp4 in the recent release of gstreamer, but either playbin2 missed those changes or isomp4 doesn't provide the correct compatibility stuff.

Source : https://bugs.archlinux.org/task/24381

    RSS FEED
  1. shbk  2011.10.19 02:30    댓글주소  수정/삭제  댓글쓰기
    nice. you helped me thanks